Jump to content
Sign in to follow this  
Blue Phoenix Ace

Site Upgrade Themes

Recommended Posts

I recently did an upgrade of the forum software and it seems to have made a lot of the themes look crummy. I've done some work to fix a lot of the problems, but I probably missed some things for certain themes. If you think something looks a bit off in some places, please let me know here and I will start fixing them. Thanks!

  • Like 4

Share this post


Link to post
Share on other sites

The info sections on profiles and the status update, member statistics and who's online boxes are all kind of hard to read with the new text blending in.

 

aG1zw2H.png

Fn97bVB.png?1

 

Other than that though things seem to working well

 

Edit: Also the topics section on the board index page has the same issue as the above list

Share this post


Link to post
Share on other sites

The dark (green) theme (and probably the other dark theme) has an ugly white border around some elements. The ones I found with this issue are the text editor and the sidebar on profiles.

 

9pWpouS.png

Also the bar at the top (the one with the "Forums", "Leaderboard" and "Chatbox" buttons) is a really dark green which doesn't stand out from the dark grey background.

 

ykqQGit.png

This is the case for the main page of the forums too.

 

Also, the heart reaction is blue, which does not fit well with the dark (green) theme. It also has a white border.

OIqtqxc.png

 

Also, if possible, could you please fix the low contrast between the quote box and text, and the spoiler box and text in the text editor? (The low contrast only occurs in the text editor NOT once it has been posted. It's really hard to read what you're typing in the spoiler box)

 

That's all the problems I've found so far, but I'll keep you informed if I find anymore.

 

(Also, I'm liking the reactions. Is it possible for you to add more or are they fixed?)

  • Like 2

Share this post


Link to post
Share on other sites

The best looking one now is default blue.

But dark blue has white around the text box so maybe invert all that.

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, Zemaddog said:

The dark (green) theme (and probably the other dark theme) has an ugly white border around some elements. The ones I found with this issue are the text editor and the sidebar on profiles.

 

Fixed this for the dark themes.

 

18 hours ago, Zemaddog said:

Also the bar at the top (the one with the "Forums", "Leaderboard" and "Chatbox" buttons) is a really dark green which doesn't stand out from the dark grey background.

 

Pain the butt to fix for some reason. I did fix the text to be more legible on the nav bar so that should help.

 

18 hours ago, Zemaddog said:

Also, the heart reaction is blue, which does not fit well with the dark (green) theme. It also has a white border.

 

Unfortunately, the color of the icon is fixed for all themes, so it will just be green everywhere. :) The white border looks OK to me, so I think I'll just keep it.

 

18 hours ago, Zemaddog said:

Also, if possible, could you please fix the low contrast between the quote box and text, and the spoiler box and text in the text editor? (The low contrast only occurs in the text editor NOT once it has been posted. It's really hard to read what you're typing in the spoiler box)

 

This was brought up a long time ago and I could find no way to fix it. It has to do with the editor's code which is out of my hands unfortunately.

 

18 hours ago, Zemaddog said:

(Also, I'm liking the reactions. Is it possible for you to add more or are they fixed?)

 

I can add as many as we'd like. :) I just need an icon and a name for it.

 

11 hours ago, Louis Hypo said:

But dark blue has white around the text box so maybe invert all that.

 

Fixed!

Share this post


Link to post
Share on other sites

Hmm, that's bad. :)

3 minutes ago, Zemaddog said:

Now none of the buttons at the top of the page work! I can't check my notifications, PMs or go to my profile

 

It was caused by my change to remove the funky stripe under the navigation buttons. I had to revert that so the stripe is back. Oh well....

Share this post


Link to post
Share on other sites
3 minutes ago, Blue Phoenix Ace said:

Hmm, that's bad. :)

 

It was caused by my change to remove the funky stripe under the navigation buttons. I had to revert that so the stripe is back. Oh well....

I'll manage with the funky stripe. It's hard to see against the background anyway due to it being so dark. ¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

LOL, it's really irritating though. Unfortunately there are four separate places where colors are defined and it can be confusing to figure out which one actually matters.

Share this post


Link to post
Share on other sites

Still some weirdness with the titles in a few places

 

YpB063S.png

 

Share this post


Link to post
Share on other sites
43 minutes ago, Momo said:

Still some weirdness with the titles in a few places

 

Are you referring to the "Who's Online" in the green theme? If so, I've just darkened it.

Share this post


Link to post
Share on other sites

@Blue Phoenix Ace Yeah, that's what I was talking about. Could just be me but the black on the dark green isn't any easier to read. It should be white or near-white in my opinion. There's no contrast at all at the moment which makes it very hard to read.

Share this post


Link to post
Share on other sites

WHY CAN'T I SEE THE RECENT TOPICS PEOPLE HAVE POSTED IN OR STATUS UPDATES?!?!?!!!!! 😫😫😫

 

(Sorry for the all caps; I am very distressed.  It was working earlier today, although I don't think I was logged in.)

(Also I'm on my phone and I've looked with both the light and dark green themes.)

Share this post


Link to post
Share on other sites

@Star Girl are you on a phone or tablet?

 

@Blue Phoenix Ace looks like the right sidebar is just completely missing if you reduce the width of the site, not just below everything else like it used to be.

Share this post


Link to post
Share on other sites

9OSUXZx.png

 

Also, the notification popup is strange. There's supposed to be text in there about what the notification actually was. It's probably black text on a black background.

Share this post


Link to post
Share on other sites

So dark blue now looks better; no unnecessary light thankfully.

And dark green has improved too. I like how the background's black at the top and it slowly turns dark grey as you go down.

Share this post


Link to post
Share on other sites

@Momo: I am on a phone using Chrome.

 

Edit: Also, using the light green theme, the search magnifying glass and menu button appear white, but the news spot (where I have to go to see what people have recently posted) is dark.

Share this post


Link to post
Share on other sites
On 8/15/2017 at 10:32 PM, Star Girl said:

WHY CAN'T I SEE THE RECENT TOPICS PEOPLE HAVE POSTED IN OR STATUS UPDATES?!?!?!!!!! 😫😫😫

 

(Sorry for the all caps; I am very distressed.  It was working earlier today, although I don't think I was logged in.)

(Also I'm on my phone and I've looked with both the light and dark green themes.)

 

Fixed! Apparently any time I change any colors, this setting gets cleared, which is not very handy...

 

On 8/16/2017 at 4:37 AM, Momo said:

Also, the notification popup is strange. There's supposed to be text in there about what the notification actually was. It's probably black text on a black background.

 

Dang.... Did it work before? Has anybody seen this with the other themes? I don't know which of the vague 40 or so color settings controls that. I can't reliably reproduce this to fix it either.

 

On 8/16/2017 at 2:41 PM, Star Girl said:

@Momo: I am on a phone using Chrome.

 

Edit: Also, using the light green theme, the search magnifying glass and menu button appear white, but the news spot (where I have to go to see what people have recently posted) is dark.

 

Fixed!

Share this post


Link to post
Share on other sites
9 hours ago, Blue Phoenix Ace said:

Dang.... Did it work before? Has anybody seen this with the other themes? I don't know which of the vague 40 or so color settings controls that. I can't reliably reproduce this to fix it either.

 

It was definitely fine before the update.

Share this post


Link to post
Share on other sites

I've noticed a problem with white appearing over the notifications on dark theme.

Share this post


Link to post
Share on other sites

Thank you! :)

 

When you click on notifications on your phone it is kind of weird... it is supposed to highlight where the text that you clicked (/touched... whatever you call it on a phone) but instead the split highlighted is slightly displaced.

Share this post


Link to post
Share on other sites
On 8/18/2017 at 0:14 PM, Star Girl said:

Thank you! :)

 

When you click on notifications on your phone it is kind of weird... it is supposed to highlight where the text that you clicked (/touched... whatever you call it on a phone) but instead the split highlighted is slightly displaced.

Unfortunately I can't control that. :(

 

Sorry I still have no fix for the notification color. I will submit a help request to Invision to get an answer for that.

Share this post


Link to post
Share on other sites
On 8/16/2017 at 4:37 AM, Momo said:

9OSUXZx.png

 

Also, the notification popup is strange. There's supposed to be text in there about what the notification actually was. It's probably black text on a black background.

 

Alright this should now be fixed for the Green theme. If this is a problem with other themes, let me know the theme name that has the problemo.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×